Conectar-se
Quem está conectado
28 usuários online :: 1 usuário cadastrado, Nenhum Invisível e 27 Visitantes

CRP-Max

Ver toda a lista


Compartilhe
Ver o tópico anteriorIr em baixoVer o tópico seguinte
avatar
Data de inscrição : 22/12/2009
Número de Mensagens : 1164
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 0

Prêmios
   :
   :
   :
Ver perfil do usuáriohttp://nintendocenterbr.forumeiros.com

O sprite não muda pra andando!

em Dom 06 Fev 2011, 00:15
é o seguinte, to fazendo um jogo de guerra(sério? tu faz só jogo de guerra né?), onde vc é um espião do brasil, e ta contra a U.S.A, to tentando a 1 hora retirar um bug horrivel, ele não muda pro sprite de andando...
codigos que uso:
Create:
Código:
global.flash=5
global.ai=0
gravity=0.8
gravity_direction=270
instance_create(x,y,obj_bracom24)
Step:
Código:
//Flash e dor\\
if global.ai>0{global.ai-=0.25}
if global.flash>0{global.flash-=0.25}
//Retira o bug da colisão e é os movimentos\\
if keyboard_check(ord("A"))
{hspeed=-8 image_speed=1 friction=0.3}
if keyboard_check(ord("D"))
{hspeed=+8 image_speed=1 friction=0.3}
if keyboard_check_released(ord("A"))
{image_index=0 image_speed=0 hspeed=0 if not sprite_index=spr_personapula and not sprite_index=spr_personaanda{sprite_index=spr_personapara}}
if keyboard_check_released(ord("D"))
{image_index=0 image_speed=0 hspeed=0 if not sprite_index=spr_personapula and not sprite_index=spr_personaanda{sprite_index=spr_personapara}}
if keyboard_check_pressed(ord("W"))
{if not place_free(x+0,y+1){vspeed=-20 }}
if place_free(x+0,y+1)
{gravity_direction=270
gravity=0.8 sprite_index=spr_personapula}
else
{gravity_direction=270
gravity=0 sprite_index=spr_personapara}
if not place_free(x+hspeed,y){ hspeed = 0 }
if mouse_x>x+1{image_xscale=+1}else{image_xscale=-1}
if speed<>0{if not sprite_index=spr_personapula{sprite_index=spr_personaanda}}
clisão com o objeto de colisão:
Código:
move_contact_solid(270,5)
vspeed=0
friction=0.3
avatar
Ranking : Nota C
Notas recebidas : C
Data de inscrição : 07/11/2010
Número de Mensagens : 429
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 19

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuário

Re: O sprite não muda pra andando!

em Dom 06 Fev 2011, 09:08
Acrecenta esse código no create:
Código:
gravity = 0.75

Ele indica o peso do objeto.

E quando for chamar osprite dele andando, tenta fazer assim.
Código:
if hspeed<0{
sprite_index=spr_esquerda
}
if hspeed>0{
sprite_index=spr_direita
}
if hspeed=0{
sprite_index=spr_parado
}

E na colisão não precisa do vspeed = 0, pois o número "5" do move_contact_solid(270,5) ja serve pra isso.

Isso resolve?
avatar
Ranking : Nota C
Notas recebidas : D-B-C
Data de inscrição : 08/09/2010
Número de Mensagens : 914
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 5

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuáriohttp://luizgm.blogspot.com/

Re: O sprite não muda pra andando!

em Dom 06 Fev 2011, 09:25
pesquise lpmov no forum, tem uma boa script para isso
avatar
Data de inscrição : 22/12/2009
Número de Mensagens : 1164
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 0

Prêmios
   :
   :
   :
Ver perfil do usuáriohttp://nintendocenterbr.forumeiros.com

Re: O sprite não muda pra andando!

em Dom 06 Fev 2011, 12:04
Obrigado Shadow10! Eu tinha usado speed em vez de hspeed, realmente, fiz uma coisa burra... Mais uma obrigado por arrumar minha burrice, sobre a gravidade não preciso pois no create ja tem xD... Seu nick vai pros creditos.
Ver o tópico anteriorVoltar ao TopoVer o tópico seguinte
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum