Conectar-se
Quem está conectado
29 usuários online :: 3 usuários cadastrados, Nenhum Invisível e 26 Visitantes

rafaelviodres1, Tedi Ripper, Willy

Ver toda a lista


Compartilhe
Ver o tópico anteriorIr em baixoVer o tópico seguinte
avatar
Data de inscrição : 29/05/2010
Número de Mensagens : 346
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuáriohttp://salathiel1337.blogspot.com/

[Resolvido]sprite_add

em Sab 05 Fev 2011, 20:02
E o seguinte, eu to tentando fazer um sistema para a pessoa carregar uma sprite.
Mais ta dando algum bug aqui, o sprite carrega, mais fica transparente.

Configurações do objeto:

Código:
Sprite: <no sprite>
Solid: false
Visible: true
Depth: 0
Persistent: false
Parent: <no parent>
Mask: <same as sprite>

No creat:
Código:
global.sprite = sprite_add(get_open_filename('Imagem|*.gif;*.bmp;*.jpg;*.*',''),1,true,true,1,1);

No draw:

Código:
 sprite_index = global.sprite;


Última edição por Salathiel em Sab 05 Fev 2011, 21:07, editado 1 vez(es)
avatar
Ranking : Nota A
Notas recebidas : A+A
Data de inscrição : 07/12/2010
Número de Mensagens : 619
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuário

Re: [Resolvido]sprite_add

em Sab 05 Fev 2011, 20:49
Reputação da mensagem: 100% (1 votos)
Descobri o motivo

Este código que está no draw deveria estar no step
O draw só aceita variáveis em forma de condição
avatar
Data de inscrição : 29/05/2010
Número de Mensagens : 346
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuáriohttp://salathiel1337.blogspot.com/

Re: [Resolvido]sprite_add

em Sab 05 Fev 2011, 21:07
Descobri o motivo

Este código que está no draw deveria estar no step
O draw só aceita variáveis em forma de condição

lol, não é que deu certo. Nunca que eu ia perceber, vlw ai cara.

Tópico resolvido, pode trancar.
avatar
Ranking : Nota C
Notas recebidas : C
Data de inscrição : 07/11/2010
Número de Mensagens : 429
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuário

Re: [Resolvido]sprite_add

em Sab 05 Fev 2011, 22:42
O problema é não ter selecionado um sprite.

avatar
Ranking : Nota A
Notas recebidas : A+A
Data de inscrição : 07/12/2010
Número de Mensagens : 619
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuário

Re: [Resolvido]sprite_add

em Sab 05 Fev 2011, 22:43
@Shadow10 escreveu:O problema é não ter selecionado um sprite.

Este problema ja foi resolvido
Não há necessidade de postar novamente
avatar
Ranking : Nota C
Notas recebidas : C
Data de inscrição : 07/11/2010
Número de Mensagens : 429
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuário

Re: [Resolvido]sprite_add

em Sab 05 Fev 2011, 22:48
O duplo post deve ter sido bug na action do PHP. tongue
avatar
Ranking : Nota A
Notas recebidas : A+A
Data de inscrição : 07/12/2010
Número de Mensagens : 619
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuário

Re: [Resolvido]sprite_add

em Sab 05 Fev 2011, 22:56
@Shadow10 escreveu:O duplo post deve ter sido bug na action do PHP. tongue
Não foi isso que eu quis dizer
O que eu quis dizer é que o problema do tópico ja está resolvido, entã não há necessidade de tentar ajudar novamente
avatar
Ranking : Nota C
Notas recebidas : C
Data de inscrição : 07/11/2010
Número de Mensagens : 429
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuário

Re: [Resolvido]sprite_add

em Sab 05 Fev 2011, 22:59
Eu tinha feito posts duplo é por isso.
avatar
Ranking : Sem avaliações
Data de inscrição : 11/10/2009
Número de Mensagens : 2184
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuário

Re: [Resolvido]sprite_add

em Sab 05 Fev 2011, 23:28
Eu tinha feito posts duplo é por isso.
Inacreditável! >_< Vou ver se algum moderador está online para trancar esse tópico.
avatar
Ranking : Nota C
Notas recebidas : D-B-C
Data de inscrição : 08/09/2010
Número de Mensagens : 914
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuáriohttp://luizgm.blogspot.com/

Re: [Resolvido]sprite_add

em Sab 05 Fev 2011, 23:32
@Markituh escreveu:
Eu tinha feito posts duplo é por isso.
Inacreditável! >_< Vou ver se algum moderador está online para trancar esse tópico.
ele quis dizer que ja fez posts duplos pq deu problema no action do php, tendeu?
avatar
Ranking : Sem avaliações
Data de inscrição : 11/10/2009
Número de Mensagens : 2184
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuário

Re: [Resolvido]sprite_add

em Sab 05 Fev 2011, 23:37
Veja isso:
@Shadow10 escreveu:O problema é não ter selecionado um sprite.

E o que eu quero dizer é isso:
joao vitor jv escreveu:Não foi isso que eu quis dizer
O que eu quis dizer é que o problema do tópico ja está resolvido, entã não há necessidade de tentar ajudar novamente
"Tendeu?" Estamos criando uma discussão paralela, que se encerre por aqui.
Ver o tópico anteriorVoltar ao TopoVer o tópico seguinte
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum