[Resolvido]Load do GM mais lento que o normal, tranca em "preparing sounds", com win 7

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

Resolvido [Resolvido]Load do GM mais lento que o normal, tranca em "preparing sounds", com win 7

Mensagem por Mauricio em Ter 01 Fev 2011, 03:24

Olá pessoal.
Estou com um problema de demora de load que está muito chato, já pesquisei no site internacional da yoyogames e outras pessoas tem isso, mas ainda sem solução. Será que alguém aqui passa por isso?

Seguinte: tenho um notebook com windows 7 64bit. Ao criar um novo projeto do GM nele, com só uma sala vazia, sem nada mais, ao apertar F5, leva 3s para o jogo aparecer na tela.

Tenho um desktop com o mesmo windows, tudo configurado semelhante, porém tem o dobro de RAM. Neste mesmo exemplo o GM leva 7s para mostrar algo na tela. Mais que o dobro da espera. Isso não ocorria com o XP 32 bit que tinha antes, era rápido igual.

Pois bem, pesquisando descobri que o problema do load que dá uma trancada na fim, é referente ao sistema de sons. Se acionar F6 (debug), dá para ver que o load tranca na hora do "preparing sounds" (mesmo o jogo não tendo som).

Tenho placa mãe com som integrado, já usei driver de audio padrão do windows, e já usei o driver de audio da realteck. Nenhum caso melhorou. Para comprovar que é isso mesmo, desabilitei tudo que é listado como audio dentro do painel de controle, device manager, e ai o GM abre uma janela na hora do load, dizendo que não há som disponível. Mas clicando ok o jogo aparece na tela instantaneamente. Ou seja, realmente é algo com o sistema de audio que está demorando demais... Como resolver?

Alguém passa por isso?

Detalhe que no notebook que abre o jogo rápido, tb é placa som onboard, com drivers padrão do windows.

Aqui tem o pessoal falando sobre problema parecido (mas o cara tinha que esperar 3mins para o jogo carregar!!) http://gmc.yoyogames.com/index.php?showtopic=458751&st=0

Aqui tb:
http://forums.yoyogames.com/forums/3/topics/35193?page=2


Mauricio

Número de Mensagens : 114
Data de inscrição : 13/06/2008
Reputação : 1
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 1
   : 0
   :

http://mbg3dmind.wordpress.com/

Voltar ao Topo Ir em baixo

Resolvido Re: [Resolvido]Load do GM mais lento que o normal, tranca em "preparing sounds", com win 7

Mensagem por Mauricio em Ter 01 Fev 2011, 16:50

Opa, resolvi !!!!

Vi que no meu note no device manager havia só uma entrada na categoria audio.
-> "High Definition Audio Device"

Porém no meu comp desktop havia várias entradas... então fui apagando uma por uma e deixando só a última o som continuou normal no windows e agora o GM leva 2s para colocar o jogo na tela! Huge Success!

Mauricio

Número de Mensagens : 114
Data de inscrição : 13/06/2008
Reputação : 1
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 1
   : 0
   :

http://mbg3dmind.wordpress.com/

Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo

- Tópicos similares

 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum