Conectar-se
Quem está conectado
17 usuários online :: Nenhum usuário registrado, Nenhum Invisível e 17 Visitantes

Nenhum

Ver toda a lista


Compartilhe
Ver o tópico anteriorIr em baixoVer o tópico seguinte
avatar
Data de inscrição : 20/01/2011
Número de Mensagens : 15
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 0

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuário

Sprites falhando

em Sab 29 Jan 2011, 18:14
Porque minhas sprites ficam falhando fica assim
Data de inscrição : 20/12/2010
Número de Mensagens : 109
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 0

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuário

Re: Sprites falhando

em Sab 29 Jan 2011, 18:25
Provavelmente você está criando os sprites a partir duma strip...
Vai ao paint, abre a imagem e vê quanta largura é que tem cada frame... anota também o espaço entre os frames...
Depois é criar outra vez e ajustar os valores...
avatar
Data de inscrição : 20/01/2011
Número de Mensagens : 15
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 0

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuário

Re: Sprites falhando

em Sab 29 Jan 2011, 18:47
não intendi e não consegui
avatar
Ranking : Nota C
Notas recebidas : C-B
Data de inscrição : 17/04/2010
Número de Mensagens : 136
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 11

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuário

Re: Sprites falhando

em Sab 29 Jan 2011, 19:34
Dê um pouco mais de detalhes para que possamos lhe ajudar. Como você carregou a sprite? Foi copiando/colando do Paint para o GM? Pelo que tô vendo nas suas imagens, você provavelmente carregou a sprite pela opção "Create From Strip", que basicamente é uma ferramenta que irá dividir as imagens (é uma ferramenta utilizada para quando se tem ou muitas imagens ou algo que possui movimento).
avatar
Ranking : Nota B
Notas recebidas : B-B
Data de inscrição : 28/02/2010
Número de Mensagens : 559
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 12

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuáriohttp://gsogaming.blogspot.com/

Re: Sprites falhando

em Sab 29 Jan 2011, 21:35
Você carregou os sprites de um strip né?
Como já disseram, veja a largura e altura das sprites, e se elas tem espaçamento entre si.
Na hora de carregar você deve ter feito errado.
avatar
Ranking : Nota A
Notas recebidas : C + B + A + A
Data de inscrição : 08/06/2009
Número de Mensagens : 1846
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 254

Prêmios
   : 2
   : 1
   : 1
Ver perfil do usuáriohttp://willy-gmbr.blogspot.com/

Re: Sprites falhando

em Sab 29 Jan 2011, 22:01
Acho q o problema não foi carregar strip.
Acho que ele salvou o sprite, e quando foi carregar deu esse erro.

Isso ja aconteceu comigo varias veses, e até com o pessoal q criou os sprites do Game Maker. Na pasta sprite do GM8, olhem em "Space" e carreguem o sprite "alien_green_strip8".

O resultado é o mesmo do sprite "defeituoso" do mario.
Bom, pelo menos no meu Game Maker tá assim '-' computador

Você pode tentar isolar cada imagem, e usar a função "crop" da aba "Transform". Depois de um "Rezise Canvas" e ajuste sua sprite.

No caso de ser uma strip, vc tem q ajustar o espaçamento de cada iamgem.

Espero ter ajduado.
investigador
avatar
Ranking : Sem avaliações
Data de inscrição : 11/10/2009
Número de Mensagens : 2184
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 106

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuário

Re: Sprites falhando

em Sab 29 Jan 2011, 22:43
Vou dizer o problema, é simplesmente o espaçamento. Isso não é um erro do Game Maker, é um erro da imagem. Tipo, se você tem uma sprite com proporções diferentes a cada sequência do Strip, vai da isso. Assim, digamos que você tem o Mário parado, e numa outra sequência ele já tá com o pé e a mão esticado. Se não houver um espaçamento definido em todas as sequências, é óbvio que vai ficar desproporcionado.

- Entendeu?
avatar
Data de inscrição : 20/01/2011
Número de Mensagens : 15
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 0

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuário

Re: Sprites falhando

em Dom 30 Jan 2011, 11:46
Valeu galera consegui.
avatar
Data de inscrição : 25/01/2010
Número de Mensagens : 908
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 16

Prêmios
   : 0
   : 0
   : 1
Ver perfil do usuáriohttp://recursos-mania.forumeiros.com

Re: Sprites falhando

em Dom 30 Jan 2011, 17:13
Ver o tópico anteriorVoltar ao TopoVer o tópico seguinte
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum