Conectar-se
Quem está conectado
22 usuários online :: 1 usuário cadastrado, Nenhum Invisível e 21 Visitantes

jhoxgamer

Ver toda a lista


Compartilhe
Ver o tópico anteriorIr em baixoVer o tópico seguinte
avatar
Ranking : Nota D
Notas recebidas : C+D
Data de inscrição : 09/11/2010
Número de Mensagens : 854
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 11

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuáriohttp://www.google.com

configurar som...

em Sex 24 Dez 2010, 18:06
Olá pessoal tenho uma dúvida urgente!!!
Estou editando um game com um botão de de configurar som.
Quero dizer, o sprite do som é um "sonzinho" com um risco.Aí qdo vc cilka o traço some e comesa o som, e vice-e verso.Alguém sabe como fazê-lo?
avatar
Ranking : Sem avaliações
Data de inscrição : 11/10/2009
Número de Mensagens : 2184
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 106

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuário

Re: configurar som...

em Sex 24 Dez 2010, 18:21
Ahh... Tirar o áudio e colocar de novo? Moleza! Saca só:

Tu usas o sprite_index para alterar as sprites, mas se estiver usando sub-imagens, o image_index. Então quando o player clicar no botão:
Código:
if sprite_index= spr_semsom
{
sprite_index = spr_comsom
sound_volume(snd_musica,0)
}
else
{
sprite_index = spr_semsom
sound_volume(snd_musica,1)
}
A função sound_volume define o volume de tal som, apenas possui dois volumes, 0 e 1. 0 é o mais baixo, 1 o mais alto.

Não exagere, não é urgente '-' Estamos num fórum de programação amador, não estamos numa empresa ou trabalho que precisemos entregar algo com urgência. Porém, o término do concurso é amanhã, isso é verdade.
avatar
Ranking : Nota D
Notas recebidas : C+D
Data de inscrição : 09/11/2010
Número de Mensagens : 854
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 11

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuáriohttp://www.google.com

Re: configurar som...

em Sex 24 Dez 2010, 18:27
não deu certo=/
avatar
Ranking : Sem avaliações
Data de inscrição : 11/10/2009
Número de Mensagens : 2184
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 106

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuário

Re: configurar som...

em Sex 24 Dez 2010, 18:35
POR QUÊ não deu certo? Sinceramente, odeio isso, quando querem que a gente adivinhe o que é. Por que não deu certo? Que erro deu? Heeinn???

'-'
avatar
Ranking : Nota D
Notas recebidas : C+D
Data de inscrição : 09/11/2010
Número de Mensagens : 854
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 11

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuáriohttp://www.google.com

Re: configurar som...

em Sex 24 Dez 2010, 18:40
Eu não sei!!!Simplesmente deu um erro!!!
O problema está no som, após configurar, o problema foi nos sprites, configurei de novo e... deu um erro no código inteiro!!
avatar
Ranking : Sem avaliações
Data de inscrição : 11/10/2009
Número de Mensagens : 2184
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 106

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuário

Re: configurar som...

em Sex 24 Dez 2010, 18:42
Cola aqui o código que a janelinha do GM mostra
Ver o tópico anteriorVoltar ao TopoVer o tópico seguinte
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum