Conectar-se
Quem está conectado
35 usuários online :: Nenhum usuário registrado, Nenhum Invisível e 35 Visitantes

Nenhum

Ver toda a lista


Compartilhe
Ver o tópico anteriorIr em baixoVer o tópico seguinte
avatar
Data de inscrição : 28/11/2009
Número de Mensagens : 443
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 0

Prêmios
   :
   :
   :
Ver perfil do usuáriohttp://animeworldmugen.forumeiros.com/forum

[Resolvido]Ajuda com rampas em engine

em Ter 19 Out 2010, 21:38
Boa noite galera estou aqui novamente pra ver se alguem me ajuda,mas agora com rampas,eu fiz uma engine para mostrar meu problema.se puderem baixem a engine e modifiquem no que precisar para que o player suba e desça as rampas.o meu problema é que o player só desce a rampa e não sobe. baixem a engine e se puderem me ajude.se conseguirem botem o link para download.
aqui o link da minha engine
Código:

http://www.4shared.com/file/eQFnBp-W/Plat.html
ate mais


Última edição por Kyuubi em Qua 20 Out 2010, 16:01, editado 1 vez(es)
avatar
Data de inscrição : 14/01/2010
Número de Mensagens : 348
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 1

Prêmios
   : 0
   : 0
   : 0
Ver perfil do usuário

Re: [Resolvido]Ajuda com rampas em engine

em Qua 20 Out 2010, 14:20
//-----------------
//-----------------
No step em que vc esta usando o code abaixo substitua pelo code MUDAR
o que eu mudei coloquei em negrito

if keyboard_check(vk_right)
{
direita=true
parado=false
if place_meeting(x,y-1,obj_slopel)
{x+=velocidade;
y-=1;}
}
//---------------
//MUDAR
//>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
if keyboard_check(vk_right)
{
direita=true
parado=false
if place_meeting(x+5,y-1,obj_slopel)
{x+=velocidade;
y-=5;}
}
//---------------

O Y estava pouco, e deve-se checar a posição X na função

Poste se deu certo.
avatar
Data de inscrição : 28/11/2009
Número de Mensagens : 443
Insígnias de JAM :

Insignia 1x 0 Insignia 2x 0 Insignia 3x 0
Reputação : 0

Prêmios
   :
   :
   :
Ver perfil do usuáriohttp://animeworldmugen.forumeiros.com/forum

Re: [Resolvido]Ajuda com rampas em engine

em Qua 20 Out 2010, 15:59
Oh cara muito obrigado mesmo deu certinho,eu já tava desistindo desse tópico que ninguem tinha postado nada,ai vc me aparece e resolve meu problema.
muito obrigado mesmo!!!!
ate mais
Ver o tópico anteriorVoltar ao TopoVer o tópico seguinte
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum