Problemas Com Design em 3D

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

Problemas Com Design em 3D

Mensagem por wac2007 em Dom 19 Set 2010, 22:53

Pois é galera cá estou eu mais uma vez pedindo a ajuda de vocês pois tenho um pequeno problema:


Como podem ver, quando eu ativo o 3D as particulas e os gráficos ficam meio distorcidos =/
tem alguma forma que eu possa "suavizar" esses gráficos?

Flws ®/

wac2007

Número de Mensagens : 521
Idade : 23
Data de inscrição : 07/11/2008
Reputação : 0
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   :
   :
   : 1

http://wac2007.blogspot.com/

Voltar ao Topo Ir em baixo

Re: Problemas Com Design em 3D

Mensagem por Kabeção em Seg 20 Set 2010, 10:30

Não vejo nem uma distorção.
Está falando dos pixel ao redor da imagem que não estão mais transparentes?

Como você esta mandando desenhar essas sprites?

Kabeção

Ranking : Sem avaliações
Número de Mensagens : 2314
Data de inscrição : 08/06/2008
Reputação : 100
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 3
   : 0
   : 1

http://blackcapapps.blogspot.com.br/

Voltar ao Topo Ir em baixo

Re: Problemas Com Design em 3D

Mensagem por wac2007 em Qua 22 Set 2010, 21:20

A mira está assim:
Código:
draw_sprite(sprite_index,image_index,x,y)

O fogo está assim:
Código:
fire = part_type_create();
part_type_alpha2(fire,1,0);
part_type_color1(fire,make_color_rgb(255,128,64));
part_type_blend(fire,1);
part_type_direction(fire,270,270,0,0);
part_type_gravity(fire,0.05,270);
part_type_life(fire,5,12);
part_type_orientation(fire,0,360,-2 random(4),0,0);
part_type_sprite(fire,sprFire,0,0,0);
part_type_size(fire,0.3,0.4,0.001,0);
part_type_speed(fire,2,6,0.1,0);

wac2007 22/09/10 à(s) 7:31 pm:

Mas é que o problema não é a distorção, e sim que as particulas estão meio "quadradas".

Já me falaram pra usar o alpha, mas o alpha apenas diminui a transparencia e não suaviza os pixels =/

wac2007

Número de Mensagens : 521
Idade : 23
Data de inscrição : 07/11/2008
Reputação : 0
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   :
   :
   : 1

http://wac2007.blogspot.com/

Voltar ao Topo Ir em baixo

Re: Problemas Com Design em 3D

Mensagem por Denis Lemos em Qua 22 Set 2010, 21:34

Não sei se no 3D isso serve, mas tente colocar no STEP dos objetos isto:
Código:
texture_set_interpolation(true)
Isto suaviza as bordas das sprites, mas também não faz nenhum milagre, acho que o problema está na edição das sprites, tem certeza que as salvou em png antes de puxar para o GM, pois se estão em um formato que não suporta alpha os pixeis perdem a transparencia !!!

Denis Lemos

Número de Mensagens : 938
Idade : 28
Data de inscrição : 17/05/2009
Reputação : 1
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   :
   :
   :

Voltar ao Topo Ir em baixo

Re: Problemas Com Design em 3D

Mensagem por Janx em Qua 22 Set 2010, 21:37

Até onde eu sei, os sprites e particulas são usados no 2D! Tentar usar eles no 3D não vai ficar tão bonito quanto deveria!
Não existe um sistema de particulas 3D, você deve criar um. Não é muito dificil se você parar para pensar, só adiciona a posição "z".

Você ainda possui a opção de usar uma DLL para 3D no GM. Basta dar uma pesquisada! Happy

Você usa o GM8?
A sprite usada possui alpha? Se for no GM7 esse é o problema. GM 7 não tem suporte para alpha channel.

Janx

Número de Mensagens : 2417
Idade : 23
Data de inscrição : 24/05/2008
Reputação : 14
Insignia 1 x 0 Insignia 2 x 0 Insignia 3 x 0
Prêmios
   : 0
   : 2
   : 0

Voltar ao Topo Ir em baixo

Re: Problemas Com Design em 3D

Mensagem por Conteúdo patrocinado Hoje à(s) 07:57


Conteúdo patrocinado


Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo

- Tópicos similares

 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum